Issue Details#130 Flow and Water-Break Logging Issues

  • Priority: Normal
  • Number: 130
  • Type: Bug
  • Status: Resolved
  • Age: 2316 Days

Description

This video demonstrates it: http://youtu.be/zyOudnxOt1E I start originally in Creative Mode (might've forgotten for a moment when I was placing the dirt originally hehe) 1:45 is where the bug blatantly appears. (3:05 is me scrolling, that is why the chat jumps)

Seemed to be able to repeat the problem by going to a new area where /prism near returned nothing and retesting.

Use the picture as a reference for the set up. Step 1: Placing the water, letting it flow downward, and break the grass. Step 2: Check /prism near everything should appear Step 3: Rollback the flow, roll back the break Step 4: check /prism near again should be fine Step 5: Place water once more, letting it flow downward, and break the grass Step 6: Check /prism near it only contains the placement of the water with the bucket Step 7: Roll back the flow + break, it should work Step 8: Sometimes the flow (only) may then show up in the log It also seemed to fail to pick up the placement of dirt blocks near by as well.

Also getting some weird stuff with WorldGuard regions (where I was owner) possibly where it wasn't detecting grass breaks due to water flowing. Only the placement and flowing of the water was detected. The flowing could be rolled back but the breaks could not. I'll check that again however because I never was able to reproduce it faithfully. In some places it just wouldn't work, in others it would.

History

sockmonkey Gravatar

sockmonkey January 17, 2013 7:52 AM

"It also seemed to fail to pick up the placement of dirt blocks near by as well."

It actually did pick up the changes made to the dirt blocks as you can see in the video. Mistakenly added that thinking of when I was in creative where creative was off.

Also, default configuration was used so logging of everything was on except creative mode placements

sockmonkey Gravatar

sockmonkey January 17, 2013 8:18 AM

Bukkit: craftbukkit-1.4.6-R0.3.jar (#2584)

Plugins: WorldBorder, GroupManager, WorldEdit, NoCheatPlus, DisguiseCraft, LWC, Prism, WorldGuard, Essentials, EssentialsProtect, EssentialsSpawn, VanishNoPacket, EssentialsChat, EssentialsAntiBuild

botsko Gravatar

botsko January 17, 2013 5:15 PM

I'll look into this today. Thanks for doing such a great job providing information.

  • Milestone → 1.0.0-Beta2
  • Version → (empty)
  • Status → Accepted
github Gravatar

Snowy EveningJanuary 17, 2013 6:35 PM

Disabling multiple-flow-actions-per-coord feature entirely because it's also what caused bug 132:resolved. Related to bug 130:resolved

github Gravatar

Snowy EveningJanuary 17, 2013 6:35 PM

Ignoring multiple flow events per coordinate needs to reset when a new bucket is emptied. primary issue with bug 130

Snowy Evening Gravatar

Snowy Evening January 17, 2013 6:35 PM

  • Status → Resolved
botsko Gravatar

botsko January 17, 2013 6:39 PM

Essentially, there are multiple "flow" events that fire for each coordinate and it just seemed unnecessary during development but trying to ignore the extras caused this issue and another problem I noticed. Both should be fixed.

Try this dev build and let me know how it works:

http://botsko.s3.amazonaws.com/Prism/Prism-v1.0.0-Beta1-20-8-g59f09c7.jar

cheesepufftyler Gravatar

cheesepufftyler July 17, 2015 4:10 AM

This issue was referenced by issue #975 ("Says no changes with everthing i do. Even globaly.").

cheesepufftyler Gravatar

cheesepufftyler July 17, 2015 4:10 AM

This issue was referenced by issue #975 ("Says no changes with everthing i do. Even globaly.").

cheesepufftyler Gravatar

cheesepufftyler July 17, 2015 4:10 AM

This issue was referenced by issue #975 ("Says no changes with everthing i do. Even globaly.").

Update Issue

Add your comments to this issue!

Creating a free account will let you immediately report issues on this project, as well as comment on existing issues, save your filters, and more!!